Что нового

Не срабатывют юниты(Service) в systemd (1 Viewer)

Статус
Закрыто для дальнейших ответов.

heroma

Участник
OLD SkripTers
Регистрация
18 Дек 2019
Сообщения
52
Реакции
40
Запуск бота через screen проходит отлично.

Пытаюсь обеспечить автоматический перезапуск бота, но реакции ноль

Код:
[Unit]                                                                    
Description=Archive bot                                              
After=network.target                                                                                                                                         
[Service]          
User=root                                                                        
ExecStart=/var/www/www-root/data/tg/tg/bin/python3 /var/www/www-root/data/tg/bot1/app.$
KillMode=process                                                          
Restart=always                                                             
RestartSec=5                                                                  
                                                                                       
[Install]                                                                           
WantedBy=multi-user.target
Код:
~                                                                                      * archivebotg.service - Archive bot                                                       Loaded: loaded (/lib/systemd/system/archivebotg.service; enabled; vendor preset: ena   Active: activating (auto-restart) (Result: exit-code) since Wed 2022-01-12 10:58:23   Process: 18440 ExecStart=/var/www/www-root/data/tg/tg/bin/python3 /var/www/www-root/d Main PID: 18440 (code=exited, status=1/FAILURE)

Помогите пожалуйста разобраться, не хватает знаний

Использую Ubuntu 18.04.6 LTS и python 3.7
 

heroma

Участник
OLD SkripTers
Регистрация
18 Дек 2019
Сообщения
52
Реакции
40
Заглянул в журнал
Код:
systemd[1]: Started Archive bot.                                                                              Jan 12 09:24:11
python[10005]: Traceback (most recent call last):                                                             Jan 12 09:24:11
python[10005]:   File "app.py", line 1, in <module>                                                           Jan 12 09:24:11
python[10005]:     from aiogram import executor                                                               Jan 12 09:24:11 python[10005]: ModuleNotFoundError: No module named 'aiogram'                                                 Jan 12 09:24:11 systemd[1]: archivebotg.service: Main process exited, code=exited, status=1/FAILURE                           Jan 12 09:24:11
systemd[1]: archivebotg.service: Failed with result 'exit-code'.                                              Jan 12 09:24:16
systemd[1]: archivebotg.service: Service hold-off time over, scheduling restart.                              Jan 12 09:24:16
systemd[1]: archivebotg.service: Scheduled restart job, restart counter is at 6.                              Jan 12 09:24:16
systemd[1]: Stopped Archive bot.

У меня несколько версий питона, но мой бот работает только на 3.7 и выше и модуль аиограм у меня установлен. Почему пишит что нет, не знаю.

В ExecStart я уже указывал разные версии, результат тот же.
 

heroma

Участник
OLD SkripTers
Регистрация
18 Дек 2019
Сообщения
52
Реакции
40
Раньше без requirements запускался, а щас нет 🤷

Топик в топку.
 
Статус
Закрыто для дальнейших ответов.

Пользователи, просматривающие данную тему

Верх